EigenD fingerer plugin does not load

Hello all, I live in Austria and I am new to Eigenharp. I have a Pico for a week now and try to learn basic techniques in Workbench.

I am on a Mac with OSX 10.14.5 (Mojave)
EigenD is version 2.1.7-community, 32 Bit.

One problem arised today:
The fingerer plugin does not load, neither directly added nor with the experimental preset. I see the plugin folder on disk, so it is here. But trying to load it gives the error “Problems loading plugin fingerer”.

What can I do?

Seems also to be the case on Windows. Double checked with 2.0.74 stable (the last Eigenlabs release), there the Fingerer agent is working.
Odd, I could have sworn that I have used the fingerer with the community edition in the past…

can you check the logs, is there any more info in the logs? is it just complaining about not finding files to load or something?

fingerer is instantiating for me on 2.1.7 community edition on mac os.
I’ll say im using the 64 bit version, but there is no difference on the builds in this regard :confused:

ok, the likely issue is you are missing the ‘User Fingerings.txt’ file, without this (even if its empty) it will fail to instantiate the plugin.
(I had this on the windows box I tried, and creating this fixed it)

1 Like

Yepp, thanks, that’s it. I knew it worked in the past :slight_smile:

Edit: Just had a look, the last Eigenlabs release automatically created an empty User Fingerings.txt file when the fingerer agent was opened the first time (and the file didn’t exist).
On Windows it is under %HOMEPATH%\Documents\Eigenlabs\Fingerer

1 Like

I don’t know where the logs are and how to access them.

I have the file ‘User Fingerings.txt’ and also ´Factory Fingerings.txt’. Made them empty one by one but no difference, the fingerer does not load.

Better revert the Factory Fingerings.txt to the original content (and best don’t touch anything in the release-2.1.7-community folder, these files are usually not supposed to be edited). If you have already edited various files there then better reinstall EigenD to be on the safe side.
The User Fingerings.txt file belongs to your Eigenharp/Fingerer user folder, not side-by-side to the Factory Fingerings.txt.
The logs are in your <userdir>/Eigenlabs/2.1.7-community/Logs directory. If you have an error message like this in the respective eigend.X.log file then it is likely the User Fingerings.txt that cannot be found. At least the error message went away when the file was there in my case:
eigend-backend: assigned cordinal 1 to fingerer
eigend-backend: loading a(’’,fingerer,‘2.1.7-community’,‘1.0.0’,1) into enclosure None
eigend-backend: relation: create(cnc(""),role(by,[cnc(~a)]))
eigend: : ignored:
eigend: : Traceback (most recent call last):
eigend: : File “pi\utils.py”, line 84, in __do_nothrow
eigend: : File “pisession\workspace.py”, line 189, in __load
eigend: : File “pi\agent.py”, line 68, in __main
eigend: : File “plg_finger\finger_plg.py”, line 322, in init
eigend: : File “plg_finger\finger_plg.py”, line 83, in init
eigend: : File “pi\resource.py”, line 98, in os_path_exists
eigend: : File “C:\Program Files (x86)\Eigenlabs\runtime-1.0.0\Python26\lib\genericpath.py”, line 18, in exists
eigend: : st = os.stat(path)
eigend: : TypeError: coercing to Unicode: need string or buffer, NoneType found

Ok, re-installed the 2.1.7-community version.
I don’t have an ‘userdir’/Eigenlabs/2.1.7-community directory.
My path is /usr/local/pi/release-2.1.7-community and there is no ‘Logs’ directory inside. I created a ‘Logs’ folder with all permissions but no log gets written.

oioioioioi …
I looked at the wrong location, far too deep.

On Mac, the path you are referring to is
And yes there is a “Fingerer” folder and yes, after I had created an empty “User Fingerings.txt” file there, the Fingerer loads. And I found the logs :wink:

Problem solved, thank you very much!


tip: EigenD has a menu option - Open Library Directory - this should take you to the right place for ‘global’ folders, and you can then go into the sub directory for the particular version of eigenD installed (e.g. 2.1.7)

useful as this works on macOS, windows and linux … (and I can never remember the locations for each platform :wink: )

Clear advantage for those who can read :slight_smile: