EigenD - macOS 10.15 Catalina - Installation

Ohh, bad luck?…

I did not say something as my previous actually post mention just move files ;-)…

The other day I did this setup and zygurt got his Pico back full of lights :wink:

1 Like

Thanks, will give that a shot!

1 Like

Also grab the log file … that might yield some info

Also check in the Mac OS system information , this will tell us if the bootloader has loaded or not.

Found this in the logs, which I’m guessing might be relevant (I’ve forgotten so much of how this works, where things are located…)

Can't find interface

eigend: <pico_manager1>: loading firmware /usr/local/pi/release-2.2.1-community/resources/firmware/pico.ihx

eigend: <pico_manager1>: can’t find interface

eigend: <pico_manager1>: Traceback (most recent call last):

eigend: <pico_manager1>: File “plg_pkbd/pico_manager_plg.py”, line 157, in download_keyboard

eigend: <pico_manager1>: File “lib_pico/ezload.py”, line 76, in download

eigend: <pico_manager1>: RuntimeError : can’t find interface from picross/src/pic_usb_macosx.cpp:201 ()

eigend: <pico_manager1>: python exception inside functor

eigend: <pico_manager1>: python exception inside functor from tmp/obj/picross/src/picross_native_python.cpp:11375 () caught at picross/src/pic_usb_macosx.cpp:1821

did you install python? as instructions 1st post?

errrrr keep pushing, some of it will come to you :wink: as they say like riding a bike? (ahah not the best fit)

1 Like

OK, just tried the all lights setup and that didn’t seem to work, but then reloaded one the factory setups (pico2), and it’s now working :man_shrugging:

1 Like

ahah, and now if you try my setup again?

Either way you got it working !! ghost-in-the-Pico

Edit: Ohh, my setup only lights up all LED Red ai think; nothing else

And now not working again. Weird. I think I’m going to park this for now and come back to it later on.

1 Like

Go for Kai ECMapper/EigenCore its really easy to play Pico this way :wink:

1 Like

Yes, I’ve also been looking at that, and have just started to get that working :slight_smile:

1 Like

Great! let me know if any more ideas…

There are many DAW and simple plugin hosts have their usefulness :wink:
Besides the “main players” (for me Ab Live - Gig Performer)
Latest I’ve found:

Id recommend NOT doing this before you have EigenD stable, as you’ll read below, its not going to solve the issue, as its not eigend thats the issue…
so, its just bringing more factors into the equations esp. as I dont use ECMapper, so can’t really support. (despite the fact the actually low level comms is all done with my EigenLite code)

ok, so it cannot find the pico’s primary usb interface …
so if you went to the system info on the Mac, under usb, id suspect you will not see the pico at all.
this would be the thing to double check
(ie. its failing to see the bootloader on the pico, so even before it uploads the firmware)

as such there is no indication that there is any ‘software problem’.
… so I doubt using EigenLite (which is what ECMapper is based on!) will make any difference.

as for why its intermittent, and then starts working, thats not too surprising…
in fact, thats why once the Mac ‘sees’ the pico, it all suddenly starts working.

so there is an oddity here, which Ive mentioned before…
I’ve found my pico is extremely sensitive these days with the usb cables, cables that work perfectly well on other devices (or even computers) don’t work, or are intermittent. even had the situation where a particular cable was ‘golden’ for the pico, then just stopped working, and another one started working … and Ive no idea why!

frankly, I do not think its the cables,
Ive wondered if its the connector on the pico… but wiggling it, doesn’t seem to make it start (or stop) working.
so, Im left wondering if its something odd in the pico bootloader firmware, that now sometimes is working, sometimes isn’t.
but then again, Ive seen something similar when trying it with a raspberry PI (running linux), so it does point to the ‘hardware’

the only positive thing I can say, is for me, one I find a cable that works, it seems to work every time.

hmm, perhaps one thing to try… see if a powered usb hub helps? (or dont use it, if you have already been using one)

1 Like

I always found those connectors as very sturdy/robust/good quality/“metal chassis”.
Never failed on me while performing; but yeah with a couple of variables in play (different MBP/Imac/macmini) different macOS over the time…

As this come up:
For me MBP+Mojave+USB hub, I sometimes do have a hard time Pico discovering, about cables, I have 3 original ones and its what I use.

1 Like

yeah… it is a weird one…
first it points to the cable, as you try a different cable , and the pico springs into life.
but then you try to the same cable with something else, and it works fine.

(annoying the first cable that stopped working was my original pico one… I wonder if its started working again :laughing: )

and indeed, Ive never see any evidence its the pico connector, as I said ‘wiggling’ around never causes an issue, and some cables work

then the other thing is… its only ever the pico, the alpha and tau, never have issues !

I will also again repeat, its not software… (eigend or mec/eigenlite)
if you look in system information, you will see the usb device is just not there… and its the same on linux too.

so all the ‘evidence’ is somewhat contradictory.

if you bring your pico(s) perhaps we can try a few combinations of cables, computers and picos…
see if there is any consistency… and see if some picos are more ‘sensitive’ than others?!


So I’m using the original USB cable that came with the Pico and as mentioned it is working just fine on an older laptop.

I’m not using a powered hub (don’t currently own one). I’m using either a USB A/C adapter directly, or an unpowered hub.

So as you say, I think it’s something with OSX and the USB system. If I have room I’ll bring the Pico.

That’s good to know. Getting the Alpha out of its case is also something I’ll try over the next week.

ummmm might be that adapter (I don’t trust USB adapters)
With Pico I don’t advice to use an unpowered USB hub (Pico is very demanding power wise)

I kind of suspected the same, as when I first had the issue, it had been a while since last using Pico… and so a few macOS versions had come and gone…
but, I can’t even say that with any real confidence, as Ive seen the same thing on a rPI/Linux.

I do agree with @keymanpal , the pico has always been very ‘power sensitive’ … and this has been a factor at times - some SoCs would only work IF used with a powered hub.
I could even see it being possible that some OS power ‘settings’ (possibly hidden on macOS!) could be having an effect… again no evidence though.

this is why it’d be handy to have a few picos, cables and computers all in one place, and see which combinations work, and not…see if we can start to see a pattern.
e.g. if we have a cable/computer/os combo that doesn’t work with pico A, does pico B work?

so bring your pico, and also the cable you were trying…

but for now, my suggestions is…
try a different cable, you might be surprised, and dig up a powered hub (its a useful thing to have anyway … make sure its usb2)
… and check the system info to see when/if its connecting, rather than firing up software - its quicker :wink:
(oh, remember you need to hit refresh, as I think the panel is not automatically updating iirc)

1 Like

My 2 Silver + 1 Black are booked :wink:

1 Like

Just to close the loop on this. @thetechnobear & I worked through some testing on the Pico connection issue today and have a fix for it. More details can be found on this thread: