Eigenharp stopped working -- looking for guidance

I haven’t used my Eigenharp in two years (last show before COVID) and I just set it up yesterday to prepare for a new show but it’s no longer working properly.
Background - I never understood the EigenD model / agents stuff etc and back in 2014 or thereabouts, Geert Bevin provided me with a single setup that just sends out OSC messages representing each key value as you touch/move them. I also use a simple Max external to send REST messages into EigenD to set individual LED colors.

This has worked flawlessly for years, I’ve never had to touch it. I’m still running 2.0.62. (I did try to install 2.0.74, apparently the last stable version) but that version won’t even open after installation.

What seems to be happening now is that, when I start it, OSC messages seem to work properly and I can send in a single REST message. As soon as I send a second message, the Eigenharp becomes completely unresponsible, no more OSC, no more ability to send REST messages, etc.

I used ‘curl’ to format the messages and discovered that when I try to send the second message, ‘curl’ gets stuck, presumably waiting for a response.

That’s all I know.

I’m game to try the latest community version but I’m wondering if anyone has any insights as to what might be happening, given that I have not updated the OS (OS X 10.14). Anything else I can try?

Right now I’m dead in the water.

Thanks in advance

Ohhh… wish I could be of some help (OSC its not my “thing”)
Do you only have EigenD on a single mac? could you compare/run it on another machine?

Maybe @thetechnobear can come up with something ?

yeah, Im talking to @david via email at the moment…

Im having a bit of a (electrical) power issue at the moment, so all my computers (except this laptop :wink: ) are off, and so is all my studio stuff… so can’t go test this.

plus I’ll be honest, I cannot remember how this ‘rest’ api stuff worked for setting leds… so id have to dig that up from somewhere.
the OSC stuff is a non issue, thats just the osc agent, connected, I assume, directly to the alpha keyboard.

once, my power is back… then I’ll go test it

HOWEVER… given @david has not changed the setup, this is not something that has been broken/changed in latest EigenD version… something else is going on.
SO… I assume/hope an install on a new machine will fix it.

but looking into it.


Anyone know where I can get prebuilt binaries for this ECMapper stuff — I pulled the source down and tried to compile it — got an error and I just don’t have time to debug this stuff (sigh) - right-clicking on the FileChooser object took me to the JUCE file where it’s defined and those methods are there!


Apparently one has to add


to the preprocessor

(Another sigh)

It’s in the repo. https://github.com/KaiDrange/ECMapper/releases/tag/v1.0.1

1 Like

yeah, I already mention that to David :wink:

@thetechnobear The latest community version WORKS — thank you SO much —