External Midi Stopped Working?

Hi. I have a new-ish Striso that I was using exclusively with external synths, but it suddenly doesn’t work anymore. I tried 3 different synths, different midi cables, plugging the USB into different ports, computer, etc. I tried resetting it, turning it off and on several times. I am definitely using the correct midi port via adapter (though I did even try plugging the adapter into the audio port just for the heck of it). It was working fine then just stopped.

I can only think maybe my mini adapter stopped working for some reason or the unit is suddenly faulty. Are there other settings I could be missing? I’ve been using it in MPE mode. Do I need to buy another midi adapter and try that?

To test and see if the unit worked otherwise, I did test the internal sound and it works. It also works fine via USB to computer (in the few weeks I’ve owned it I hadn’t even tried those modes until it stopped working via DIN midi).

Edit: I went to bed, turned everything on this morning and everything works as it should. Very strange. Is there some type of time period power down reset or something?

update: Came back to it later today. Everything ok for the first 15 minutes or so, then nothing (internal synth still works fine). Guess I’m going to have to send it back. Bummer.

update #2: Same thing as update #1.

update #3: I went back to the previous firmware, and so far no problems! :smiley:

Well, today I join the “MIDI won’t work” club! I have used the QuNexus Red and the Striso for months with my old iPad Air 2, which won’t load new software and has only 16 gig memory, but has been working fine for those months. Both controllers work great with the laptop PC, but all my favorite apps (GeoShred, ThumbJam, and Roli 5D) are only iPad. Seems like “Apple” just sent out a ray that says “don’t let him use MIDI controllers anymore.”