MEC with Soundplane on OSX


I am trying to get the soundplane working with MEC on OSX (running 10.12.6 currently). I have compiled the the project and am trying to get a hello world happening. Everything seems to run but I don’t get any output to the console. I tried running as my user and as root to see if it was a permission issue. I have attached the console output. What you can’t see if that the LED on the soundplane does light up when I run MEC with this configuration, I just don’t see any output.

When I try running just the splite library (which MEC uses) I am able to see the output to the console, so I am not sure where exactly I am failing here. Also, where might I see some examples of other config files or documentation so that I could try outputting to different locations (OSC, MIDI, etc)?

Thanks for any and all advice.

sudo ./mec-app mec.json
mec_app initialise
loaded preferences
“mec”: {
“soundplane”: {
“app state dir”: “.”,
“steal voices”: “true”,
“voices”: 4
“mec-app”: {
“console”: {
“throttle”: 0
mec api initialise
mecapi_proc start
soundplane initialise
creating SoundplaneDriver…
SoundplaneHandler enabling for mecapi
starting SoundplaneDriver…
soundplane init active
mec_app running
Available Bus Power: 500 mA
isochronous interface opened, 2 endpoints
^Cmec_app int handler called
mec_app wait for mec thread
mecapi_proc stopping
device deinit
Soundplane::reset model
frames: 15296
wait: 41852
error: 20
gaps: 4
devices cleared
mecapi_proc stopped
mec_app mec thread stopped
mec_app exit
mec_app exit handler called

welcome to the forum :slight_smile:

lets be clear where you are at… as im a bit unsure…

not quite sure which json file your using, but the logs show that you only have console output, neither midi not osc is defined.

Id recommend you try sposc.json as for the soundplane (as a starting point), this will output t3d osc messages on port 3123 which you can check with oscdump
(you can enable the console, by getting rid of the underscore before ‘console’)

also, can you try the ‘dev’ branch of mec,
ive been recently doing a bit of work in this area… an honestly, I cant quite remember where master is at (curse of the developer, you’re always a bit ahead of your users :slight_smile: )

splite should be fine, but bare in mind this is a library , not an ‘end user’ app,
im using it quite happily within MEC and on bela (particularly on salt),
but id need more specifics if its not working as you expect.

Hi Mark!

Thanks so much for the speedy reply!!

I’m using a very basic file in order to test proof of life. I tried sposc.json, and even with removing the _ on the console I don’t see any output. I tried using PD to bring in the OSC the same as I do with the Soundplane app but I don’t get any packets (I can see in the terminal that the frames seem to be counted). I tried logging using netcat but I don’t get any information there either.

However, if I try the touchtrackertest I get perfect tracking on the console.

My goal is to get this running on my laptop to dial in my configuration and then run it on the raspberry pi. I have ORAC and MEC installed on the PI already and I can try on that machine later tonight to see if that makes a difference.

sorry for late reply…

in sposc.json you will see the console is ‘disabled’
(as in normal running you don’t want the console to be written to constantly :wink: )

json does not supporting commenting in files, so to disable elements, I put an underscore ( _ ) in front of them, just remove the underscore and you’ll get console output.

to debug osc , you should use oscdump…

personally, id do this on the rPI, as the Linux tools are a bit easier
(also as I note on the readme, macOS is only really a dev platform, I don’t really support it at the moment… which means at times it maybe broken if I happen not to be using it at the time :wink: )

id recommend you use the dev branch for now… just as that’s what im working on

and initially use the MEC project and build that,
as I don’t keep the binaries up to date on all platforms on the dev branch of Orac … I just update them when im working on them and finally for release.

Hi Mark,

No worries on the reply.

It works! When I download the dev branch of ORAC and use the MEC binary in that distribution with the sposc.json from the CORE folder (it isn’t in the PI folder) it works. It takes about 1 minute before output starts but it is there. I don’t get any luck with the master branch, but it could just be me.

I noticed that the touches seem to run 1-15 instead of 1-4. The console seems to imply that there is a “max voices” parameter set to 15. Is that something I adjust in addition to the “voices” parameter in the json file?

Fantastic. Thank you!

1 Like

do you see the line
"max voices : " …

it should be set to 4, from what i can see in sposc.json if not then I need to check…

(it will default to 15 if i cannot find the parameter)

but please bare in mind, dev is working a on a new api that I put together so might have a quirk or two… ive been testing it mainly on Bela, but yesterday I did switch attention over to MEC so might be some updates in next few days.