Spot of trouble with my Tau... Advice sought

So, recently my Tau has periodically stopped communicating with the base station once in a while. The lights cut out, and it goes dark for a few seconds and then comes back.

I thought maybe it was a loose cable, but that doesn’t seem to be it. Even if I wiggle it in the socket or try and smack it, it seems fine. But then I’ll turn or, change hands and the tau cuts out again. I can’t make it happen consistently however, so I’m unable to diagnose what is going on.

I’m thinking maybe I need a new cable, or something, but not sure if that’s actually what is going on, as when I actually try to mess with the cable deliberately, it seems fine.

When this happens, the light on the base station indicates that I am connected and power is on, and the software doesn’t crash out, and eventually it comes back.

This is a bit of a problem for live performance, so I thought I’d see if anyone has any idea what might be going on.

I think I am going to try with another computer, in case it’s something about the USB bus on this one.

Hmm, it doesn’t sound like what you are experiencing, but one thing I can think of that I’ve encountered is some rare problems related to the electrical power. John explained what the problem was a couple of years ago. Iirc it was something to do with a ground loop and could for instance be caused by certain sound cards connected to the computer. Again, I doubt it is relevant, but if you have tried everything else I guess it could be easily ruled out by testing on a different circuit with nothing but the Tau connected to the computer…

The only other really weird issue I’ve had was EigenD related and started happening after I had done some minor changes in my usual EigenD setup. The lights suddenly disappeared and after a while the light on the base station indicated it was disconnected. After days of trouble shooting (including a full reformat of the computer) it finally got solved by adding an audio agent to my setup, even though I was just using midi. I have no explaination for what was going on, but certain that the audio agent was what fixed it. But, in my case, the lights didn’t come back on. So still highly unlikely to be relevant for your case (sry!).

Interesting. You know, it might be related to my setup. I should try different setups and see if I can duplicate the problem with those.

Given that even abusing the cable, I can’t cause it deliberately, and it only seems to happen once in a while while I moving, I’m suspicious that some kind of feedback from the keys is stumping EigenD. I notice once in a while, the keyboard “off” button also gets triggered by whatever it is.

So maybe there is something in my setup. Tho I have been using it for years, and never had this issue. I’m also suspicious of recent OS updates.

Haven’t been able to duplicate the issue so far on my windows laptop, so maybe it’s host related.

Wish I could get more intel on what exactly triggers it, but so far it just appears to be random.

Is this while playing? not playing? heavy processing? with what OSX?

It happens while playing, but also has happened just after picking it up. So in all cases, it was moving. This is why I suspected the cable. However then when I try to make it happen by deliberately jiggling the or bending the cable, or giving it a hard rap to see if it happened when it got a shock, nothing happens. Everything is fine. I can’t seem to predictably do it on cue. The behavior is like as if I were to unplug the cable and plug it in again, but happens at random, even while playing it laying flat on a desk with no cable movement either.

I’m using windows 10 pro.

I have also had it on OSX on a different machine.

Could it actually be the cable, but maybe only cutting out periodically when the cable is in some particular position or something?

1 Like

Hard to diagnose… maybe an email to John/Eigenlabs could help?!

1 Like

That’s a good idea. I’ll throw him an email and see what he thinks. My best guess is the cable, but can’t prove it.

1 Like

a few years back , I had problems with my Alpha with a dodgy connector…
when occasionally it would either completely cut out, or id start getting random keys press, or some random keys light up. what I also noticed, was if I unplugged the cable from the alpha and then plugged it in again - often it would not work.
BUT as you say, when it was working, just wiggling the cable would not necessarily make it fail.

unfortunately, in my case, it had to go back to eigenlabs to get fixed… but they were really great about it, and its been fine ever since.

hopefully for you its just the cable…
I guess first thing I would do is, see if you can buy a new cable…
(I used it as an excuse to get one of the longer ones :slight_smile: )

also when it cuts out, does the basestation light go red?
the reason I ask is… iirc the basestation has different colour lights
green = eigend/computer is connected an all ok
orange = no eigend/usb/computer
red = no eigenharp

so this should tell you if its the usb cable or the eigenharp end.

its been a while so might have got this wrong.
but you can test it, when its working by pulling out eigenharp cable… and seeing if colour changes, and similarly disconnecting usb cable from basestation.


Thanks Mark. I’m concerned that it might be the unit too. It may need servicing. I’m hoping it’s just the cable tho.

As for the base-station light, no, when it happens, it remains green. So it sees the tau and computer, but the tau cuts out randomly from time to time. Makes me wonder if maybe there is a bad solder join on the connector.

I have a background in electronics and a great setup here to do electronics work, including an SMD rework station. I’m just loathe to try and take it apart to look. I’m also loathe to send it overseas and the resulting wait and inevitable tangle with Canada customs. They are to put it mildly, insane.

I might just try another cable for now, and then if that doesn’t work, take the next step.

I do suspect that it’s as you suggest, something to do with the connector. Possibly an old solder join on one of the pins that slowly wore down over years of the gentle tug of gravity on the cable.

Unfortunately you can’t open Tau to fix it :frowning:
After Eigenlabs open/close it , they put it on a special jig to recalibrate all the keys… so not something we can do ourselves.

might be worth reflowing cable joints though.

hmm, this is odd…

Ive just tested (tau+basestation) and it goes orange (*) as soon as I disconnect the tau.

so this implies that EigenD things the tau is still connected
if you open launch workbench you can probably verify that.

I guess there is a possibility that the cable/connector is causing not on/off, and so its constantly reconnecting… this would probably be noticeable in the eigend logs.

(*) funny, basestation light never goes red… i much be imagining that :wink:

for me when it went awry, I had two issues

  • whenever i unplugged the cable and plugged it back it (eigenharp end), it often would not start… basestation led would remain orange
  • very occasionally whilst playing, suddenly it would glitch out, and i might get one column of keys have the leds change randomly… so it was like a comms error… rather than turning off completely

note: this was with an alpha and basestation pro, so there is a possibility it might be slightly different.

1 Like

Thanks for the info. Good to know about the consequences of opening it up. That’s the sort of unknown that always makes me resistant to opening something up unless there is absolutely no other option.

I don’t seem to have any of that other behavior, nor was anything strange in the log.

I have since apparently stopped the behavior. It looks like it was indeed the cable. I did open up the terminator at the 'harp end, and reflowed the solder on the pins (melted and reset) and applied new stiffer heat shrink tubing to help make the join resistant to bending.

The problem seems to have vanished.

I’m going to place an order for another cable just to have a spare on hand for shows if this suddenly starts happening again.

My best guess is that the ground pin was shorting onto another pin occasionally while moving the cable around. Tho which I couldn’t tell you. It’s pretty tight in there and not a solder job easy to do without a proper smd heat station and a big blob of flux. … Be exceedingly difficult with a soldering iron, as there is little to no room for a solder tip.

So thankfully that seems to have got it. I think the Tau itself is working great, but over time just in use, the cable just wore down near the pins.