EigenD community release 2.1.7

EigenD release (2.1.7) available for macOS 32 &64 bit, Win32, Linux 64bit, Linux ARM 32bit

UPDATE: Ive updated the win32 version, so that it no longer requires runtime-1.0.1, it uses 1.0.0 like previous versions. Id recommend updating , and then you can delete runtime-1.0.1

Please read included release notes for important information and installation notes.

  • updated to latest Juce framework (4.3.0)
  • improved 64 bit support macOS
  • fix macOS 32 bit to python from /usr/local/pi
  • improved linux build
  • fix eigenD hanging on exit
  • workbench: select agent menu, pressing letter selects first agent
  • updated release notes and introduce install notes into doc.


1 Like

Hi Mark, or anybody who can help.

I can’t get 2.1.7 to run, it tries to boot but shuts down immediately. I’m on a 2012 MBP, High Sierra, Runtime 1.0.1, resources and have just bought a used Pico. I can get 2.0.74 to run but it crashes the computer on shutdown which is why I think I should be running 2.1.7.

I have another MBP running El Capitan, will try on that one later.

And I seem to have lost my breath control somewhere among the way as the cello and clarinet have stopped working (only had the Pico for three days).

what do you mean by shuts down?
did you read the readme/install - it contains important information.
i assume you downloaded the 32bit,
(as the 64bit needs a bit of fiddling to get working, and id not recommend unless your familiar with the software etc)

my guess, if its not starting at all - is the python installation is wrong, so either you’ve downloaded the 64 bit, and not installed it correctly - or something is wrong with the runtime.
but that’s a guess given ive no info to go on…

one thing that would be useful is if you can grab the log file and share it somewhere.
(you can see with 2.0.74 where it us, open library folder)

note: also there are various version of mac os in the past which had pretty poor handling of usb, causing kernel panics if you don’t quite EigenD before pulling out the Pico from the usb.

2.0.74, is pretty old, so there are quite a few fixes in 2.1.7 - including resolving some issues with macOS. ( i think introduced around el capitan iirc, but was along time ago !)

I double click the icon in the finder apps folder and 2.1.7 looks as if it’s going to start, the icon appears in the dock, bounces a couple of times than disappears again. I’m not unplugging the Pico while EigenD is live and I’ve tried both with and without the Pico plugged in. 2.0.74 works ok when running but I have to force quit or it shuts the MBP down.

I’m pretty sure I installed exactly according to the readme file. I’ll try a new, clean, install tomorrow on my spare MBP running El Capitan and see if it exhibits the same issues.


did you install the 32bit version?
I need the eigend.0.log from ~/Library/Eigenlabs/2.1.7-community/Log to have any change of knowing whats wrong.

(given its just not starting, Id say its almost certainly your runtime install is not correct)

I installed Runtime 1.0.1 and EigenD 2.0.74 works ok (and just shut down without crashing the computer). 2.1.7 does not generate a log file Just tried to start it and no new log file appeared).

I’ll do a new install on the other MBP later and keep you posted.

k, 2.0.74 is a red-herring you will not get it to run stable - thats one of the issues Ive fixed

odd, should be a log file

try running from the command line

/Applications/Eigenlabs/2.1.7-community/EigenD.app/Contents/MacOS/EigenD --stdout --noauto

this will dump it to the terminal, and also prevent the default setup loading.

Same issue, I’ve copied and pasted from terminal below :-

Chas-MacBook-Pro-2:~ Chas$ /Applications/Eigenlabs/2.1.7-community/EigenD.app/Contents/MacOS/EigenD --stdout --noauto

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file ‘/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist’

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file ‘/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist’

locking /usr/local/pi/release-2.1.7-community/bin/libpic.dylib

locking /usr/local/pi/release-2.1.7-community/bin/libpia.dylib

locking /usr/local/pi/release-2.1.7-community/bin/libpiw.dylib

locking /usr/local/pi/release-2.1.7-community/bin/libpie.dylib

open lock file /Users/Chas/Library/Eigenlabs/Lock/EigenD.lck 3

locked lock file

release root: /usr/local/pi/release-2.1.7-community

log:using portbase 55555

ImportError: No module named site

ImportError: No module named site

Chas-MacBook-Pro-2:~ Chas$

I’ll try a new install before doing anything else.

yup as expected, thats the run time not being install properly…

thats an odd one, and not one I get (Im on 10.14.4)
it might be a red-herring, but not seen or heard of it before.

Sorted it by reinstalling Runtime. Many thanks for the help.

1 Like

Sorry for the thread revival, but I’m having some issues.
Specifically, the cello sound is incredibly distorted. It’s like there are 2 instruments playing at the same time, with one of them not changing note.
I’m using my pico after following the install guide with 2.1.7 and am on a 2019 intel mac running 10.15.7.
I haven’t installed the resource pack. Are the IRs with the resources?

yes, the convolver IR’s are in the resources, you’ll need to pull these out.
or perhaps someone can post/dm them if thats all you need.

hopefully this should resolve the issue ( * )

sorry, Im packing for superbooth and will then be away… so cannot really help more till Im back next week.

let us know how you get on


( * ) just check the release notes - Im pretty sure the convolver is ok on intel Macs… but I know I disabled it on arm both Macs and rPI … as I need to get appropriate versions of the underlying fft lib to build on these.

I’m around if you need some files…
I will also going thru some updates on my machines, will take a look.

Too easy. I’ll fix it later when I have a bit more time, but good to know.
I have all the resource files backed up, so it’s just a matter of following the process.