EigenD - macOS 10.15 Catalina - Experiences

Hi Mark, and lovely member of Eigenharp players.

I installed eigenD 2.1.7 community 64bit and Python version 2.7 on macOS 10.15 Catalina.

It was able to launch, then run with Workbench on macOS Catalina, but the [alpha keyboard 1] agent has disappeared, and it could not recognize Eigenharp alpha itself.

Quick report from Japan.

1 Like

I’m not a member of apples dev program, so I won’t have access to it till next month,
so won’t be able to test till then…

did you carefully follow the instructions for 64 bit installation in the release notes.

the 64bit version of EigenD will not work without the 64 bit version of python, and setup as detailed in the above pdf.

if you have followed the above, and its still not working then I’d need to see the latest eigend log file.

this might give us a clue, but im not sure I’ll be able to do anything until I can get Catalina on my MacBook pro.

general for others…

I would recommend you do not upgrade to a new major version of an OS without checking first,
(unless you have a spare machine you don’t usually use, in which case, feel free to be the guinea pig, and report back :slight_smile: )

I will usually upgrade one of my ‘spare’ machines :
a) during the public beta, perhaps not immediately though… as sometimes its best to wait for the ‘dust to settle’
b) when I know ive got time to do something about issues that might arise.

macOS Catalina

Ive not watch the apple keynote, is macOS Catalina dropping all 32bit support?
( I think apple were threatening this)

this is not a big deal… Ive been running the 64 bit version of EigenD for a long time without any issues,
the only thing that could do with a bit of tidying up is the install process.
(unfortunately, I still dont have access to the ‘runtime install’ source code, so I think I need to build that from scratch :frowning: )

1 Like

Thank you for your reply.

OK, I carefully pay attention to the release notes PDF and try to reinstall it again.

I’m a beta tester not a programmer, so I don’t know technically thing, but if I’ve noticed something under the influence of Catalina,I will report here.:slightly_smiling_face:


Cool, let me know if instructions are not clear.

( I think a few have got the 64bit running so hopefully accurate!)

1 Like

Hi everyone, long time no see.
Japan is still like summer :hot_face: :sunny:

I finally succeeded in linking Eigenharp alpha itself that was not recognized on Workbench with EigenD 2.1.7 (64bit) that had already been confirmed to start on macOS 10.15 Catalina (Beta).

Until this problem was resolved, the Base Station and Eigenharp alpha connected via USB could not be recognized on macOS 10.15 Catalina. To solve it, there was not enough ritual to cast the spell :woman_mage::sparkles:of the following terminal command.

The following is a quote from the past Eigenharp Forum.

-The library path needs to be extended further to be able to load all libraries which are distributed across the whole folder.Here’s the script I ended up with:

ED = / usr / local / pi / release-2.1.7-community
for i in [$ ED / plugins / Eigenlabs / * $ ED / * $ ED / modules / * $ ED / modules]; do export LD_LIBRARY_PATH = $ LD_LIBRARY_PATH: $ i; done
$ ED / bin / eigend --stdout --debug

-This is also solving the issue with the USB vendor & product IDs I observed-I missed that these numbers are canged by the driver upon initialization.

-I missed your udev script.Once I had it installed, I could run the starter script with user permissions-which solved the issue that running it or the call to the binary with root permissions resulted in different errors.

I finally understood the problem above, so I can safely move to the official version of macOS 10.15 Catalina that will be released soon.

macOS 10.15 Catalina
EigenD 2.1.7 community (64bit) :ok:
Workbench :ok:
ableton Live 10.1 with LivePad agent on EigenD :ok:
Eigenharp alpha + Basestation via USB :ok:

Good luck to everyone :+1:


Thank you for testing this and reporting back to us. :slight_smile: I’m usually one OS behind, just in case. But good to know my Eigenharps will still work when the time comes.


It’s my pleasure :slightly_smiling_face::+1:
I am very interested in new and unfinished things, so I love trying out these uncertainties.

thanks @Hiromitsu

so to be clear, you’re saying you needed to do the following to get eigenD to start?
(the the standard application link in /Applications would not work?)

Im a little surprised that this is the case… but will investigate.

Ive been waiting on the release (which I believe is on Friday? ) , I guess I’ll update my iMac then.
though, there do seem to have been quite a large number of manufactures/developers saying they are ‘not ready’ which is a bit concerning.

(i’ve not checked my hardware/software stack, to see if there are any known problems yet :frowning: )

my guess is once 10.15 is released, we may have a number of eigenharp owners turning up for help on installing the 64 bit version - so Id be grateful for anyones suggestions/comments on the current release notes e.g. if Ive forgotten to mention anything :wink:

EDIT: given Catalinas imminent release, Ive created a post on the installation process, so the information is in one place - mainly it’s pulled from the 2.1.7c release notes.

(Ive renamed this thread, to help differentiate them)

Id gratefully receive any feedback on it,
I’ll obviously update if any other information/tips crop up as people upgrade.

one ‘small issue’ is its hard for me to do a ‘fresh’ install, since I’ve obviously upgraded to 64 bit on all my macs already… so what I will encounter is issues related to a 10.14 mac with EigenD 64 bit going to 10.15. - so any experiences outside that would be good to hear.


Hi, @thetechnobear

Thanks your kindly support and effort every time :slightly_smiling_face:

Although EigenD 2.1.7 was able to start without any issue on macOS Catalina Beta with clean installation, Workbench could not recognize Eigenharp Alpha or Base Station connected via USB.

When I entered the terminal commands I found in the forum, I was able to recognize them on Workbench.

It is my ignorant personal guess, but there may have been a problem with USB device recognition.

what the above cmds do is ensure the various eigend modules can be loaded, one of which includes the alpha modules - but im not sure until i upgrade why that would be necessary, as was ok in previous macOS versions

1 Like