Help with Windows installation

Hey, all!

Just got a used Eigenharp Pico off eBay, and am trying to get it set up. The flash drive it came with doesn’t appear to be original, and only has some .pkg files on it, which aren’t usable for Windows as far as I can tell.

I came across this thread: How to install and run EigenD in 2023+ [wiki] - #6 by thetechnobear

And have been trying to follow the instructions, but it isn’t very straightforward. The thread leads to a release notes page on GitHub which says it’s important to read the installation notes, but I can’t find any link to said installation notes.

Nonetheless, I’ve done everything I can find to do between the linked thread and the GitHub page, including installing the latest version of Python, installing the Windows driver, and downloading and trying to install EigenD-gpl-2.1.7-community-win32.exe.

However, for that last one, I’m getting the message: “Please install the EigenD support package before installing EigenD.” And I’ve not yet been able to determine what or where the EigenD support package is.

Thanks in advance for your help!

Editing to add: I’m running Windows 11 Home on an Asus ROG Zephyrus M16 with an i9-11900H processor and 24 GB RAM.

Hi there.

Unfortunately this is a bit tricky, now that the eigenlabs website is down.

It’s been discussed a few times here, what we host and not - but let’s keep it as simple as possible as you’re just starting out and want to get going.

Let’s start by what do you have, as this would be simplest route.

What’s on the flash driver?

—-

For others…

I can throw the driver up into GitHub.

The runtime … has anyone used the python installl from python.org… or does someone need to/has already uploaded runtime package?

Finally resource image , again has someone uploaded?

I can’t put this on GitHub, as it contains licensed software. Also it’s very outdated/ large.
It’s not really needed but for a newcomer it’s going to be very confusing that factory patches don’t work without it.

1 Like

Yay, the Eigenlabs website is online again:

Edit: Apparently only the download page is reachable. So let’s download while we can…

Am currently uploading everything to a Google Drive folder. Because of the license situation I’d rather share the link on demand. So if the official download site should become unreachable again best send me a PM.

3 Likes

oh, thats cool… actually seems most of the links are working too, its just the ‘entry’ home page that seems problematic.
but for sure, Im going to go download the stuff now, just to have it ‘available’ , so can decide what to do in the future.

edit:

  • downloaded everything, and now stored on my NAS - but its good if others do this too “just in case” ™
  • I’ve updated the wiki page here, to attempt to clarify a little…
  • I’d previously uploaded windows driver to my EigenD repo, which is (currently) the critical one.

mid term (not now, as no time), I’ll look into how we move forward in the case website goes now.


@chuckmcknight , id advise to download the official install initially, check things are working.
then once you have it running, you can simply install the EigenD package from my repo.

3 Likes

Excellent, thank you! I had tried the Eigenlabs homepage, which still seems to be down, but didn’t realize their downloads page was up. I’ve now downloaded and installed everything from there, including the runtime, drivers, and stable release. I then installed the community release.

The app seemed to install fine and opens without error, but nothing is happening on my Pico itself, attached via USB. The tutorial video suggested that when EigenD is running, the Pico would simply turn on if plugged in, but that isn’t happening.

Is there something wrong with my device? Or is there another step I’ve missed?

Here’s what EigenD looks like for me, by the way:

I’ve tried loading the default setup, and that doesn’t do anything either.

Directly to computer? Pico itself needs good cable and “all power” from USB.
The usual recommendation to try:

  • another cable?
  • another usb port?
  • a powered usb hub in between?
1 Like

Thanks for the suggestions!

I tried different USB ports, and it isn’t making a difference. The computer does make the chime to recognize that something has been plugged in or unplugged, but nothing happens on the device itself, and nothing pops up on the screen.

I can see in Device Manager that there’s an “Unknown device” listed under “Other devices” that appears when it’s plugged in and disappears when unplugged.

I don’t have any other Mini B USB cables or powered hubs lying around. I can try getting ahold of some and seeing what happens.

1 Like

Might not make a difference but you can try another setup file, for example Experimental Setups/Pco/Modular Synth (only one sound, and loads faster)
Or Experimental Setups/Pico/Midi Basic (only outputs MIDI).

did you install the windows driver?

1 Like

I did. And later I installed it again, just to be sure, haha. Still nothing.

I tried a few other setups, but no joy there either.

I put an order in at my local Best Buy for a high quality cable and powered hub, so I’ll go pick that up shortly and see if it makes a difference.

1 Like

hmm, it not recognising device … seems to me like the driver is not picking up.
you might want to check logs, see if its got any failures etc, that might give us some more info.

also can you confirm the usb device id that its seeing.

Where would I look to get the logs?

As for the device ID, it’s just showing up as “Unknown device.” The “Details” tab under “Properties” gives this value: USB\VID_2139&PID_0001\5&2CE07162&0&5

Edit: I found a section under info called “Matching Device Id,” and it’s blank.

Well, I got the better cable and powered hub, and it still isn’t doing anything. :frowning:

In other news, I found the logs folder. There are a bunch in there. Do you want them all? Or need me to clear them out and do a specific action to reduce the noise?

you actually only need the latest log… which is numbered zero.

but the easiest thing to do is … delete all the logs, then run it again.
(preferably do a clean reboot, and don’t have the pico plugged in)

also can you check that the Eigenharp driver has not for some reason been ‘sandboxed’ due to something like unverified developer. ie… its been installed but is not active.

background:
the pico goes thru two stage initialisation…
basically firmware is downloaded to it and then it re-intialises (and appears as a ‘different device’)

before loading the firmware the pico is seen as 0x2139 / 0x001 (as you see in your logs)
then, after loading the firmware, it changes to 0x2139/ 0x0101

so we know, that for some reason… your firmware is not being loaded.

HOWEVER, Im pretty sure, that if the windows driver is installed, and working.
that your pico would show up as something like “Eigenlabs Pico Pre-load” in device manager, not unknown device.

@NothanUmber , you run windows … can you confirm this?
i.e. plug in pico without EigenD running and see what its called in Device Manager.

My main fear here is that for some reason, the Eigenharp driver is NOT picking up pico.

has anyone run an Eigenharp on Windows 11?
could it be that the driver no longer works on windows 11.

the driver is very old, its 32 bit only, perhaps Windows 11 has dropped support for it.
unfortunately, we do not have the source code, so we cannot rebuild for new windows support.
I do have a ‘plan’ to resolve this, but its not something I can do quickly.

also… I only have one (older) windows laptop, but it cannot run windows 11.
it used to work fine with the pico.
(however, Ive since reinstalled windows… and want to keep it ‘clean’ for testing my future plan)

the driver works on win 11 for me. But it was always a struggle to get it to work. Best check in the device manager whether there is an exclamation mark next to it. If yes Play with disabling and reeabling, connecting the Eigenharp/Basestation to different USB ports etc. until it is shown without exclamation mark. If it does once then it usually stays that way.
Caveat: I installed it on Win 10 and it still works after the update to Win 11. So I never actually installed it on Win 11…

2 Likes

when you ‘have trouble’ with it… does device manager show as ‘unknown device’.

I’d kind of expect to still recognise the device, even if it was ‘having trouble’ actually talking to it.

also does window tend to ‘sandbox’ the driver on install?

(but, Ive very little experience with it on windows so Ive do not know how these things ‘appear’)


good news about windows 11… I fear one day, the driver will stop working, and we need to move on.
though in fairness to Microsoft they are very good with backwards compatibility, unless certain other companies :wink:

Okay, I followed these steps to get this log.

  1. Unplugged Pico and closed down eigenD.
  2. Cleared all logs from the folder.
  3. Restarted my PC.
  4. Plugged in Pico (via the new cable and powered hub).
  5. Started eigenD and allowed it to load its default setup for the Pico. (Still nothing on the device itself.)
  6. Used Tools / Open Library Detector to get to the logs folder.
  7. Quit eigenD.
  8. Copied the log file and renamed it as a text file so I could upload it here.

eigend.0.log.txt (151.0 KB)

As for the driver being sandboxed, what are the steps I would take to determine this?

A few things:

  1. Check whether you can see the Pico in the device manager. It should look like this:
  2. The standard setup is fairly complex. You have to set the right mode via mode keys to hear anything.
    Best load the setup “Example Setups/pico/1 (Modular Synth)” as a first test.
  3. Ensure that you have selected an audio output. By default this is empty. Go to Window->Audio Setttings (after the Modular Synth preset is already loaded) and select your audio device (if you know that your soundcard supports ASIO that usually gives you better latency, if not choose DirectX 10, this should work in any case)
    Now you should hear synth sounds when pressing keys on the Pico.

I cannot see the Pico in Device Manager. Here’s what it does look like:

The highlighted “Unknown device” is what shows up or disappears when I plug or unplug the Pico. Here are its properties:

I’ve now repeated the process using the Modular Synth setup and selecting ASIO for my audio device. Here is that log:

eigend.0.log.txt (46.8 KB)

However, my understanding is that regardless of sound, the Pico should at least light up when connected with eigenD running, right? Absolutely nothing happens on the device.

From everything I’m seeing so far, it seems like it’s the driver itself that simply isn’t working. Otherwise, it would show up in Device Manager, right?

disable/enable, uninstall/reinstall the driver with Pico plugged out/plugged in at different USB ports (best with all other USB devices being unplugged for the moment) until you see the entry in the device manager. (This takes some trial and error unfortuntately I didn’t find a recipe that always works). Before you see that it doesn’t make sense to start EigenD (do not have it open while doing the driver installation experiments), it needs the driver to run on Windows.
Fortunately, once you get the driver to work once it will stay that way (at least for me).