No lights on Pico with fresh Windows 10 install

Long time no see everyone.
Tonight I went through the process of reinstalling the EigenD software. The first time Windows couldn’t figure out what to do with the Pico. So I uninstalled everything and started again.
Followed: Unable to connect tau to microsoft windows - #17 by thetechnobear

  1. Plug in Pico, and see it as an unknown device
  2. Unplug Pico
  3. Install Drivers from Eigenlabs website
  4. Plug in Pico to see that the drivers and device are detected. Success.
  5. Install Runtime.
  6. Install Community 2.1.7
  7. Open EigenD.

The Pico responds to input, plays Clarinet, MIDI etc. However none of the lights are lit up. When I press the Menu button nothing happens to the lights on the keys, but they still respond correctly.
Is this something that others have seen before?
I could also try my Alpha, but it’s getting late.


1 Like

Hi, long time no :eyes:, indeed!
Hm, perhaps you could put a powered usb hub in between - just to be sure that it has enough power? Not sure whether switching off the lights is an implemented measure to cope with less energy?

Hi @zygurt welcome back :wink:

No mention about what cable you are using… can you try with a shorter, good quality one?

Thanks for the welcome back.
I’m using the USB cable that came with the Pico. So it is quite long, but has worked flawlessly in the past. I’ll see if other cables help the situation.
I’m plugged directly into a USB 3 port on the motherboard. I’ll try a USB 2 port as well.

I’ve also just tried in on a Last Gen Intel Macbook Pro. But it’s on 12.6, and automatically updates as a work machine… so I will need to look at it more. Last time I used it 6 months ago the lights worked. This time loading EigenD and I’m not getting anything from the keys, even in MIDI mode with the correct MIDI output set.

I’ll keep exploring today.

EDIT: I think the light circuitry might have died. I’ve tried with multiple cables and get the same result. About to try with the Alpha.
From memory the Pico normally flashes lights when first plugged in. That doesn’t happen either.

EDIT 2:The Alpha’s lights work correctly, so I assume it’s an issue with the Pico hardware. Looking elsewhere on here it seems like it’s not the only one to fail recently.

Can you try this setup @zygurt
A Pico user setup with a simple talker - ALL Lights RED

Unzip and drop it inside user setups
user 53356 ~ (6.7 KB)

Well that’s successful.
Hmm, how confusing then.
If I then load the default Pico setup, all of the lights turn back off.

1 Like

sorry, Ive got family visiting at the moment, so not had time to look into this…

for sure, seems a bit odd, I can’t think of a reason why a particular setup would loose the leds, unless the ‘light’ connection had been removed …
I guess, Id take a look in workbench, see if you can reconnect the light connection?!

(though doesn’t explain why it works for others)

1 Like

ok, thats good ! and proves no hardware fauilure :wink:

So, opening the Pico Standard Setup only the top right is red ( Metronome on/off)
and bottom Octave Down/up lit in amber

Maybe you were expecting the keys them self lit? say with tonics? that was later user modifications…

So, I plugged it in last night, and the lights functioned as they should. Metronome and octave buttons lit up, and the keybed lit up when pressing the menu button. No idea what changed.

1 Like

… it just needed a “warm up”…

All good then!! Have fun playing :wink:

1 Like

for some reason I sometimes have this with my Pico… and also its become quite ‘particular’ about which usb cable I use…
Ive a usb cable that I used to use with the pico ALL the time, but now Pico really doesn’t like… yet it works perfectly ok with other devices.
Ive a feeling, but no proof, it’s something to do with the usb connector… just because thats the ‘mechanical’ bit, so perhaps on the pico it’s a bit loose, so poor connection.
but the connector is obviously kind of ok, as with another usb cable it works fine every time.

1 Like