[SOLVED]Can't get EigenD to work on OSX Catalina 10.15.6

I use EigenD 2.1.7 community on my 10.14.6 (Mojave) OSX without issues, but after I made sure I have Python 2.7.x on my new Catalina Mac and followed the other instructions from here: EigenD - macOS 10.15 Catalina - Installation

I can’t get it to work. It always looks like the app is a 32bit app.

If I try to open it I get this message:

Made sure I copied the same binary I use on Mojave.

Does anyone have any suggestions?


Ohh, sad to hear… I’m still on Mojave…
double check that you have EigenD-gpl-2.1.7-community-x86_64.pkg - macOS 64 bit.???

can you report the following (change the path to where you have EigenD installed)

lipo -info  /Applications/Eigenlabs/2.1.7-community/EigenD.app/Contents/MacOS/EigenD 
otool -Lh /Applications/Eigenlabs/2.1.7-community/EigenD.app/Contents/MacOS/EigenD 

Ouch … I’m sooo embarrassed to admit that I did try to run the 32bit version :slight_smile: and that is precisely what it looked like…

On my old mac - I did have the 2.1.7 but it was the 32bit version which worked fin up until Catalina. I just copied that assuming that it was 64bit. Thanks @thetechnobear for suggesting I use the lipo

“Mistrust the obvious!”

However - I did have to downgrade my Python to 2.7.10 and the link to download it referenced here: EigenD - macOS 10.15 Catalina - Installation does not work any more so maybe take a look and fix that link.

Once I installed the exact 2.7.10 mac 10.6 version of Python everything was back to normal.

Thanks for your help and sorry for the alarm…


hey, no worries… we all do it …

don’t know how many times, Ive been tripped over by something i was absolutely sure I’d checked :wink:

anyway glad you got it working, thats the main thing.

fixed the link in the above topic… was the link the only issue, or did I miss something else?