Striso board Firmware updates

The first firmware update is out. This release fixes the tuning of the internal sound, which was 270 cent sharp. Thanks @rdjvonk for reporting.

To update the firmware, connect the Striso board to a computer with the square button pressed, now it should have a blinking red light and should appear as a flash drive. The current firmware version can be found in INFO_FW.TXT.

For this release first update the bootloader by copying strisoboard_v2_bootloader_v1.1.2-0-g32b1c18.uf2 to the Striso board. The Striso board light should turn blue momentarily and start blinking red again.
Now copy the firmware update striso_control_2021-03-05_v2.0.2-0-gc9cfde1.uf2.

Please let me know if it works.

1 Like

I just registered to report the tuning issue! Let’s see if I can get this to work.

Edit: it works!

Thanks! It works.

I didn’t see any blue light but just dragging the two files to the striso was enough to make it work. In my case, the red light kept blinking. After disconnecting and reconnecting, the tuning was ok. Thanks again for solving this, I can go back practicing again;)

Worked fine for me. I also didn’t see a blue light, it just stayed red, but the bootloader and control updates didn’t have any problems.

PS: Came up as a drive right away in Windows 10, so no need to use my Android phone this time. Nice work!

I couldn’t resist spending some time on the sound, it now reacts more to pressure and the motion effects are a bit more balanced.
Furthermore the sensitivity settings for pressure and velocity now work for the internal sound, just as the ‘motion sensor off’ setting (those settings only worked for MIDI before).

Here it is: striso_control_2021-03-11_v2.0.3-0-g49f3b02.uf2

3 Likes

Edit: remove panic typography

I can’t connect the Striso as a a flash drive
There is no sound from the internal synth.
Striso is not recognized as MIDI input (tried Plasmonic in stand alone and Logic)

On first try my Mac wouldn’t “see” the flash drive although the red light was blinking. This was through a USB hub.
On 2nd try, it took a while but finally it showed up. Directly connected to my Mac mini. On trying to open it no file would show up. Mouse as a spinning wheel. When the files finally show up everything freezes. I try to take a screenshot. After a while, the flash drive is no longer there and I got a message of “external drive was not properly ejected”.

Now I can’t connect the Striso as a flash drive. No red light blinking. It’s been connected while I write this and nothing happens.

I’ve tried this on my Mac mini 2018 and on my MacBook air (older device) both on Big sur, macOS 11.2.2

Problem solved. I got detailed instructions as to how to resolve the problem and I got the Striso updated.

Maybe @pierstitus could keep these guide in the website. Sooner or later others will run into issues too.

1 Like

For clarity: There’s a bug in the bootloader that was shipped in the first batch. For those boards it’s important to update the bootloader that can be found in the first post. If that fails the backup bootloader can be used, let me know if you have problems. I’ll also open a troubleshooting topic later.

Here’s a new bugfix release that fixes the midi aftertouch which broke in the last release. Aftertouch is now a bit more sensitive too. Here it is: striso_control_2021-03-14_v2.0.3-1-g9328d67.uf2

2 Likes

Thanks! Keep up the great work!

Updated without problems. Thanks

I just tried updating in a Mac and after a long while with the red light blinking, the Striso appeared as a volume and I tried to copy the bootloader file.
After several minutes it ejected without finishing I guess and now the Striso doesn’t respond and is stuck with a red light and it isn’t detected by the computer.

Please, I need help, thanks.

Welcome @csantin,
You were unlucky (and lucky :wink: ) to be in the first batch which has this bootloader issue.

Luckily there’s another backup bootloader.

Plug in the Striso board with the up button pressed. One down led and a faint up led should light up.

Install dfu-util, which can be installed on a Mac with homebrew (assuming you have homebrew) with ‘brew install dfu-util’

Now download the .bin version of the bootloader: strisoboard_v2_bootloader_v1.1.2-0-g32b1c18.bin and run the following command:

dfu-util -a0 -s0x8000000:leave -D strisoboard_v2_bootloader_v1.1.2-0-g32b1c18.bin

Now the usb drive should work reliably, and you should be able to copy the latest firmware.

I’m sorry for the inconvenience, let me know if it works.

That worked, thank you very much.

One note though, I had to indicate the serial number for the internal flash device in the dfu-util command with the -S parameter.

This number can be obtained with
dfu-util --list

I’ve just released firmware version 2.0.4, which adds TRS MIDI out support.

Using TRS MIDI the Striso board can be connected to synthesizers that have MIDI in. It works both with MPE and with normal MIDI, switch by pressing the settings (square) button and the buttons on the top row. See the settings reference that also came with the Striso board in the box.

The source code is now up to date and the releases can be found on Releases · striso/striso-control-firmware · GitHub

1 Like

That was quick! Thanks Piers! Will have a go this evening.

There’s a small firmware update, v2.0.5.

This fixes the portamento that was not working in some situations.

Furthermore some experimental features are added:

  • Bohlen-Pierce tuning, the last two keys of the tuning row are now used for the non-octave Bohlen-Pierce tuning, which has 13 notes in a tritave. See the thread Microtonality and the Striso - #7 by pierstitus
  • Crosstalk filter to reduce the effect that touching multiple keys has on the perceived pressure on other keys. This can be toggled with [settings]+[B3] (the highest B).
2 Likes

I’m getting an issue where when dragging the UF2 file onto the board, it ejects from the computer midway through (I am running macOS Catalina). When I reconnect it, it is fine, but the firmware version isn’t modified (it is “Firmware version: striso_control_2021-05-31_v2.0.5-0-gef984ad”).

Oh wait, this means that it worked! I guess I just had to try a few times to ensure that it copied correctly.