Unable to connect tau to microsoft windows

#1

Can any Win 7 (or win10) users help me please (or anyone else).? I cannot install Eigenbrowser. Nothing shows in Device Manager, and I have no Eigen browser icon or link, ir indeed any other eigen icons on the desktop. I have installed all 3 software downloads and the feedback window after install says all software is installed…

My Tau show a green flashing led in column one (left hand bottom trigger key) and all the leds on the neck light when touched.
The disable and enable switch lights orange at the percussion keys…
Otherwise, no sound or anything else…

On a positive note, the keys seem extremely reponsive, (if led on indicates note on ) and are much more responsive than the keys of any of my Ztars, although changing and controlling required touch pressure between both instruments when played together (with either hand) will be a big challenge…
I really hope I can somehow get the Tau to work.

thanks in advance

ritchie
bg

Just got half a Tau
#2

you are not looking for EigenBrower, you are looking for EigenD
it should be in your program files, under a directory Eigenlabs.

when you start EigenD , you then need to load a Tau setup… nothing will appear to happen until you do this :slight_smile: so just pick the Tau factory setup.
(you can then select to load this at startup, so its automatically loads when you start eigend)

what is the colour of the LED on the basestation - solid green?

the green flashing on the tau, means the basestation has connected to the Tau.

this should disappear once you start EigenD - which Im assuming it doesn’t.
this means EigenD is not ‘finding’ the tau.

which is not surprising, if you say you cannot see it in Device Manager!

ok, so two thoughts:

a) hardware related e.g. bad usb cable or similar…
I would have thought even if the eigenharp device driver was not working, you would still see USB device (basestation) in device manager … though it would probably be labelled as ‘unknown’ or similar.
… so check to see if you have device that appears/disappears in device manager as you turn the basestation on/off - if not, then Id look at the USB cable, or try a different port on your windows machine

b) device driver related
make sure you check (a) out first, as otherwise you’ll be wasting time not this step :wink:

so when you turn on the basestation, from memory you usually get a notification of a new device appearing - this is the basestation
then when you start eigenD and load a tau setup, then another notification appears saying its got a new device. (the tau being spotted)

(… its a while since I last installed the drivers, so I might be mis-remember this, and might be different on different versions of windows - but I think this is generally what you see)

but for some reason, sometimes the Windows device driver appears to fail to install properly,
ie. it’s there, but it just doesn’t detect the basestation.
(unfortunately I dont have the device driver source code, so I cannot find out why this happens)
so if you have proved (a) is ok, then try to uninstall the driver and repeat.

I usually found doing it a 2nd time resolved the issue, the I admit, its something Ive not done a huge number of times, since once it starts working - its seems ok!
(and newer versions of the EigenD software do not need a new driver install)

@NothanUmber has the most experience here of using/install EigenD on windows, so he might have something to add to the above…

otherwise, if you still have problems, I’ll see if I can get some more specific advice by playing with my Windows 10 setup.


EigenBrowser, is installed with the main EigenD package, and is generally accessed thru the EigenD menu I thought it was still ok on Windows, unlike the mac… but I don’t use it, Like Duncan , I do all my setup directly in Workbench

#3

I also haven’t used EigenBrowser for a long time (EigenCommander is currently broken in the community release because we moved to a newer Python version and haven’t adapted it yet).
Workbench is probably all you need, as @thetechnobear said. If your setups become more complex and you catch yourself doing the same steps all over again several times then creator might be worth a look which allows to script setups instead of clicking:

The steps I would look at:

  • install driver: is the driver appearing in the device manager? (E.g. Eigenlabs Instruments/Basestation for Tau as far as I remember) If no: unplug, uninstall, install and plug in the instrument until it does. The driver can be stubborn initially, so you might have to repeat the cycle a few times. But if it worked once then it will work forever fortunately
  • start EigenD and load the Tau default setup from Factory setups/tau/Standard Tau Setup
    At this point the lights on the Tau should light up. If you have installed the resources then the soundfont based instrument should also work. Don’t forget to set your audio card under Window/Audio Settings in EigenD (if your device is ASIO compatible then this is probably your best bet)

To edit the setup, go to Tools/Workbench.

#4

Actually, EigenCommander works on Windows. I use it a lot, so I create my setups in Windows and then copy them to my Mac when I’m done.

1 Like
#5

ok ,this is all a bit off-topic, so please feel free to skip :slight_smile:

@ritchie did you manage to get it to work?


@kai I’ll try to remember to add a note about the VC++ redistributables.

48khz sample rate : to be clear this is because, the headphone output is always at 48khz, and I found the down/upsampling pretty inefficient. so if you turn off the headphones its not relevant (and not relevant on the Pico)
also its a bit of a trade off, if you run lots of plugins , then EigenD will use more (~10%) CPU processing these at 48kHz, compared to 44kHz (assuming same buffer sizes), so at some point the balance tips over :wink:

EigenCommander - yeah, to be clear, EigenD didnt break anything,
on the Mac , Apple released an macOS update which broke one of the python UI libraries it uses.
unfortunately, the fix is to use a newer version, but the issue is to do this we need to go to a much newer version of python and the lib, which breaks other (UI related) things… and Ive not been able to figure about exactly whats needed… (despite spending quite a bit of time debugging it)
so until Microsoft break it, it should be working fine on Windows.


I also started exploring creating a new C++ version of EigenBrowser, but its quite a bit of work, which I just need to find the time to get around to doing…
I really like the idea of performance focused UI, a kind of sidekick to Workbench.

I originally intended to ‘just’ extend Stage, but the issue is, Stage communicated with a completely different protocol ( * ) to EigenD than EigenCommander/Browser, so its not really practical.
(*) this was due to supporting iOS, and its much more ‘limited’ in its coverage…

2 Likes
#6

Thanks for making me aware! Haven’t tried it for too long, honestly haven’t touched my setup for months - and exclusively used Workbench to set it up.
But EigenCommander can still be handy for some Belcanto-ing! Will have to give it another try…

#7

I happen to have a fresh win10 installation on a laptop right now, so I can give this a go tomorrow if you aren’t up and running by then. I have used EigenD on both Win7 and 10 before and I believe several other Eigenharpists in here use Windows, so I don’t think you need to worry about whether it will work. There are probably just a couple of hurdles that might not be obvious when you aren’t familiar with what is what yet.

Just got half a Tau
#8

Moved this thread to the Eigenharp topic.

The lights suggest that you have a correct connection to the base station, so that’s a good start. I’d suggest going back to the release notes (are you installing the Community release? EigenD community release 2.1.7) and seeing if you have missed a step; note that you need to read both the original Eigenlabs release notes and the Community release.

At least on the Mac, but I think Windows is the same, the EigenBrowser and EingenCommander apps no longer work. It’s not a big deal, Workbench provides all of the same function. The applications you need to be able to run are EigenD and Workbench.

I’m not a Windows user so sadly can’t help beyond the above suggestions.

#9

Many thanks for your help Duncan

I shall persevere further this evening…

regards

ritchie
bg

#10

Many thanks Kai.

regards

ritchie
bg

#11

I don’t know if you are up and running by now, but I just installed EigenD here. On freshly installed up-to-date Win10:

  1. Installed Windows drivers from Eigenlabs.com (EigenD-Drivers_1.0.10.exe)
  2. Installed Runtime 1.0.0 from Eigenlabs.com (EigenD-Runtime-1.0.0.exe)
  3. Installed Community Release 2.1.7 (EigenD-gpl-2.1.7-community-win32.exe)
    (I didn’t install the optional resources file from Eigenlabs, as I never use the contents)

…and connected the Tau. When starting EigenD I then got an error telling me “MSVCP110.dll was not found”. So I installed “Visual C++ Redistributable for Visual Studio 2012 Update 4” from Microsoft (https://www.microsoft.com/en-us/download/details.aspx?id=30679). I first tried the x64 version, but that didn’t help, so then I installed the x86 version as well.

And that was it. EigenD started correctly, scanned for my plugins and selected the default Tau setup. Up in the EigenD toolbar you should set your Audio Settings. I believe TheTechnoBear mentioned once that 48kHz is the most CPU friendly sample rate, so I always go for that.

1 Like
#12

Hi Mark… Thanks
I have been trying all day and most of yesterday re/installing and uninstalling and re/plugging the USB cable.
No further forward at all.

Still have green light on the basestation and green flashing leds on the TAU and percussion keys master over/ride led illuminated orange.

I tried to clean the system and load load from the old 8gig flash drive. No joy either…
I gave up after teatime and played Ztar for some light relief, cos my eyes are shot with gazing at the screen for 2 days…

I shall try tomorrow or Tues with a totally clean to eigenharp laptop and try again. Then try to clean the regustry and temp files in my first laptop.
thanks for your help all…

regards
ritchie

#13

Sad to hear that it’s not a smooth experience for you. Yepp, particularly these drivers can be stubborn.
Perhaps it helps to play around with either plugging in the Basestation before or after the driver installation. And best check whether the driver was detected in the device manager before starting EigenD - perhaps having EigenD running prevents the driver from cleanly unloading, making a reinstall more difficult.
But fortunately, if you got it to run once then the driver is working all the time and you just have to plug stuff in and play - at least that was my experience with various Windows machines where I tried it.

#14

Hi Kai…

I shall follow the above religiously tomorrow or Tuesday…
I also have a win 10 laptop so I shall start with that.
Many thanks

regards

richard
bg

#15

@Ritchie did you confirm windows could see the basestation?
theres no point in keep reloading the drivers, if the usb device cannot be seen…

#16

Hi

No, windows sees nothing. I shall try using another win7 laptop and see if I can get any further forward.

Regards
Richard
BG.

#17

moved this to it own topic, with more descriptive title :slight_smile:

ok…some of this might be pretty basic, but we need to start at the beginning :slight_smile:

so the following is on windows 10, but it is basically the same on all versions, though device manager may look different, and might need manually to refresh after connections etc.

please do ALL of the following… so we can be clear if you have a hardware issue or not.

also for testing purposes , connect the basestation directly to the computer, do not use a usb hub.

( i assume below you have tau connected to basestation)

check hardware

a) uninstall the drivers… do not disable, uninstall!
b) shutdown machine, disconnect base unit
c) boot windows
d) start devicemanger
e) power up basestatation and connect it to machine

the basestaion will quickly flash red (starting), amber (basestation up - no instrument) , green (basestation read, with instrument)

windows should make its (annoying) happy chirpy sound that a device has been connected.

in device manager, you should now see an ‘unknown device’ , (note: exclamation mark)

Ive also hightlighted the hardware id, so you can see this is for the basestation…

if this does not appear you have a hardware issue
… as this is with no drivers installed.

the issue could be:
a) bad usb cable
b) incompatible usb port (needs to be usb 2.0)/ other hardware issue on your machine
c) hardware issue/usb port on basestation

next step install the drivers…

keep devicemanager running.
a) disconnect basestation

b) install the drivers from the eigend website,
i just run the dpinst.exe , and it will say all is good and install.
if not resolve that issue :slight_smile:
(becareful if windows whinges about unknown developer etc)

(it may be some versions of windows need you to reboot here)

c) now connect basestation
again, windows will make its happy chirpy sound to say new device connected.
now in device manager we will see device reconized…

see, no exclamation mark, its got a proper description. same hardware id

if its still unknown, then try reinstalling drivers (again make sure you properly uninstall them)

Run eigend

ok, so at this stage Windows can see the basestation, but what happens is when you run eigend, it actually downloads firmware to the basestatioin to connect the tau (clever stuff!)
so lets check this happens correctly

so start EigenD (program files/eigenlabs/eigend)
(again keep device manager running)
then load the factory/tau setup
(you can click of default setup at top right, to make it load this every time you start if you wish)

this takes a while, as its a pretty big/complex setup!

when you do this, windows again will make its happy chirpy sounds to say a new device is connected (your tau :slight_smile: )
now in device manager, if we look carefully we will see the eigenlabs device has changed… see description and hardware id.

if this appears correctly then once the setup completes loading the leds on the tau will change to reflect the setup, and you can start playing…


notes:

  • if you are having hardware issues, then id do things like change the cable for one you know works (tested with another device), try another usb port on your machine, try another windows machine

  • i’ve had eigend work on many versions of windows, that shouldn’t be an issue, and certainly the first hardware step should work on everything, as it basic windows functionality - nothing to do with eigenharp software.

  • the above is for the standard basestation, (the small one, separate wall wart) , but the procedure is identical for the basestation pro… but the hardware id has a different PID.
    (I think description might be slightly different, but id need to boot it up to check… but my guess is you have the standard basestation anyway)

  • necessity to reinstall driver…
    I should balance the comments about the driver being ‘awkward’ to install, this is not always the case, it just appears to be some particular combinations of window versions / computers.
    e.g. on my laptop, the drivers install and work first time, every time … (for testing purposes I routinely uninstall/reinstall stuff :slight_smile: )
    so it is important to check the hardware is functioning if things don’t appear to work, rather than just keep reinstalling the driver in blind hope it might fix it!

3 Likes
#18

Hi Mark

Very many thanks for your very comprehensive assistance and screenshot help…

I have got as far as Factory Setup in EigenD…
So hopefully, I should be in business soon.
Totally Fantastic!

a cople of points.

  1. Can you briefly list the files that I should copy to the 8 gig Eigen flashdrive (I shall delete the existing Apple Mac setup on the drive ) so that I can more easily set up the Tau for my win 10 laptop and also another win 7 laptop?

  2. The EigenD plugin scanner finds nothing and is empty, although I have tons of plugins.

again, thanks a zillion trillion for your help.

best regards

richard
bg

#19

so tau is now seen in device manager? and is showing the setup lights?
(i.e not the green flashing one in the bottom?)

what was the issue?

absolutely no idea… actually no idea what’s on there already!
all you need is the stuff that on the Eigenlabs website, latest versions.
(you could use my community release of EigenD https://github.com/TheTechnobear/EigenD/releases)

in the plugin scanner make sure the paths are correct.
(windows is a little inconsistent on what users use, so its possible the defaults are not where you have your plugs)

note: it will only load 32 bit plugins. 64 bit you will need a 32 to 64 bit plugin bridge, or host the plugins in a daw ( or similar) and then use midi. (this was recently discuss here )

honestly, most of us use a DAW or a ‘performance host’ e.g. something like Mainstage, GigPerformer, this actually has performance benefits as it moves VSTs, both synths and effects onto separate cpu cores.
… and most of those can simultaneously host 32 and 64 bit VSTs.
(at least for now, lots of talk about 32bit being dumped… but I think it’ll be a while yet)

1 Like
#20

Thanks for all the help.

I am still unable to connect to win 7 correctly.

In Device Manager, (on a fresh win 7 laptop)

  1. I have ; “Egenharp PSU (with Audio Capable firmware)” so that seems fine.

  2. I can see all the red lights and green setup selections when I select them on the neck. (however I cannot edit or change them)

  3. I cannot start the metronome (unless I select it in Stage Drummer.)
    If so, I can start metronome and hear clicker and bongo via soundcard

  4. I cannot browse metronome instruments or voices in Stage.

  5. Given the above, it seems as if the Tau loads no soundfonts, or vst’s.

  6. Plugin scanner flashes once and then disappears, and shows ‘scan failed’ and neither good or failed plugins show. (I could see ‘good plugs’ like CS80 and Synclavier, on the previous laptop (win 7 ) but could not access or play anything)

It seems as if the Tau is not loading anything at all…

Q) What is the ‘drag and drop’ into eigend for?

Q) Is it likely that I have a damaged basestation which won’t load correctly? or alternatively, a damaged instrument?

I shall follow Kai’s setup and try an install on a separate win10 laptop next week if all else fails.
thanks for all the member efforts and help so far.

regds
richard
bg